Android开发环境配置(基于Ubuntu10.10,Eclipse3.5,Android)


由于假期要做Android手机软件开发,于是在Windows下已经把开发环境配置好了。现在要在Ubuntu里面配置一下。

具体的配置过程见:ubuntu下配置jdk+eclipse+android sdk 写的比较详细。

这里说一些自己遇到的问题的解决方法:

1.配置Java环境。可能是第一次配置吧,居然把jdk路径搞错了,输入java -version居然提示的是jdk6版本,这里大体说一下自己的安装过程:

a.去Oracle官网下载JDK,目前linux下最新的版本是jdk-7-linux-i586.tar.gz,解压出来一个jdk1.7.0文件夹,放到/opt/java/下面。

b.配置环境变量:

sudo gedit /etc/environment

输入密码,然后会打开一个文件,在文件中输入以下三行

export JAVA_HOME=/opt/java/jdk1.7.0
export JRE_HOME=/opt/java/jdk1.7.0/jre
export CLASSPATH=.:$CLASSPATH:$JAVA_HOME/lib:$JAVA_HOME/jre/lib

sudo gedit /etc/profile

在此文件中添加以下四行

export JAVA_HOME=/opt/java/jdk1.7.0
export JRE_HOME=/opt/java/jdk1.7.0/jre
export CLASSPATH=.:$CLASSPATH:$JAVA_HOME/lib:$JAVA_HOME/jre/lib
export PATH=$JAVA_HOME/bin:$JAVA_HOME/jre/bin:$PATH:$HOME/bin

c.配置默认JDK版本:

sudo update-alternatives –install /usr/bin/java java /opt/java/bin/java 300  
sudo update-alternatives –install /usr/bin/javac javac /opt/java/bin/javac 300  
sudo update-alternatives –install /usr/bin/jar jar /opt/java/bin/jar 300

d.检查

sudo update-alternatives –config java

e.到这一步,在终端中输入java -version应该就能看到已经是最新版了。如下图。

2.安装ADT。单击Eclipse窗口的Help->Install New Software,在弹出的窗口中单击Add,在Name中输入“ADT Plugin”,在Location中输入https://dl-ssl.google.com/android/eclipse/,单击OK。等待Pending结束后,勾选列表中的“Developer Tools”,单击Next。
在这一步中ADT安装可能失败,可以参考《Ubuntu下eclipse安装ADT时遇到org.eclipse.wst.sse.core 0.0.0缺失的一个解决方案

正在安装eclipse的插件…可是这里一直安装不上,一直报错,然后果断取消了插件的安装。

3.重新安装eclipse。接下来怎么办呢,最后的思路是重新安装eclipse。首先卸载掉在Ubuntu软件中心里面安装的eclipse,然后到官网下载了一个最新版本。一路安装好后再配置android就没有错误了。

发表评论